right alt+s doesn't go for Polish keyboard

  • Problem
  • Updated 1 year ago
  • Solved
Archived

This conversation was archived and is no longer visible to community members.

The keybinding you use for saving (right alt+s, in windows) cannot be used for Polish programmers' keyboard (the only keyboard layout used in Poland) because right alt+s is bound to 'ś' - a very common character in my language.
By the way you'll run into more character problems if you bind right alt + a character

Tomasz Cichecki

  • 0 Posts
  • 0 Likes
  • sad

Posted 4 years ago

  • 3

Karolina Kuczko

  • 0 Posts
  • 0 Likes
Is anyone taking care of this problem? Is it going to be fixed?

Giacomo 'Peldi' Guilizzoni, Official Rep

  • 2122 Posts
  • 153 Likes
Hi guys, we'll take a look soon, sorry for the delay. This one is hard to fix since we don't have a keyboard that shows this issue...perhaps we could order a polish keyboard online somewhere?

Karolina Kuczko

  • 0 Posts
  • 0 Likes
There is no special polish keyboard :-) You just have to set polish keyboard settings on your OS - Polish(programmers), not Polish(214).

Giacomo 'Peldi' Guilizzoni, Official Rep

  • 2122 Posts
  • 153 Likes
Oh, I feel dumb now. Thanks for pointing this out, we'll take a look soon!

Krewetka

  • 0 Posts
  • 0 Likes
Soon?

It's a year later and I this problem still exists :(

Shortcut for "save-as" is theoretically "ctrl+alt+s" but even pressing only "alt+s" shows 'save as' dialog instead of our polish letter ś.

It's really annoying when you forget about it and have 'save as' dialog while entering text.

You don't even have to change keyboard settings to test it.

Simply change Balsamiq so only the full combination of 'ctrl+alt+s' opens 'save as' dialog.

Giacomo 'Peldi' Guilizzoni, Official Rep

  • 2122 Posts
  • 153 Likes
You're totally right, so sorry about it. We have tried repeatedly to reproduce the bug, but without a Polish keyboard we haven't been able to do it. Our new employee Paolo has a Swiss keyboard at home, which might help. He's going to look at this bug next week, promise.

So sorry.

Karolina Kuczko

  • 0 Posts
  • 0 Likes
It's OS settings not physical thing, to have polish keyboard settings on you computer just follow this instruction (for windows): http://www.conversationexchange.com/r...

But the problem is with shortcut 'alt+s' not with keyboard, could you just turn it off? Or at least make it switchable by a user from settings level on even in the registry? Anything...

For me it was impossible to work (I stopped using Balsamique becouse of that) when every text on a label I had to write in notepad and then copy it to the mockup.

Giacomo 'Peldi' Guilizzoni, Official Rep

  • 2122 Posts
  • 153 Likes
Just a quick note to let you know that 2.0 is now live: http://blogs.balsamiq.com/product/201...

jan.mysior

  • 2 Posts
  • 3 Likes
Hi Giacomo,
The new 2.0 release did help with the alt+s issue (great work on the Symbols btw!), but it "uncovered" another polish symbols problem. Now I can't input a "ż" sign (alt+z) because it does the Undo instead. Can we please restrict the Undo to just the ctrl+z combination.

This is even more destructive than the alt+s problem and still requires copying and pasting from notepad just as Mrs Kuczko wrote.

Giacomo 'Peldi' Guilizzoni, Official Rep

  • 2122 Posts
  • 153 Likes
Hi jan, what OS are you on?

jan.mysior

  • 2 Posts
  • 3 Likes
Windows 7 (32 bit)
Regards,

Jan

Louanne Poisson

  • 791 Posts
  • 20 Likes
Hello,

So sorry for this inconvenience. I have added your comments to the issue, and escalated it to the top of the heap. Thank you for your patience, Jan.

Jakub Tymowski

  • 0 Posts
  • 0 Likes
I'm sick of trying to get rid of that problem. I think I will sell this shitty laptop as I'm not able to write in Polish !!!! THIS IS HOPELESS we live in 21 century and people are still against people :(

Giacomo 'Peldi' Guilizzoni, Official Rep

  • 2122 Posts
  • 153 Likes
Hi Jakub, is the ALT+z the issue? Are you on the latest? We'll make sure ALT+Z doesn't behave as CTRL+Z this week, promise.

Jakub Tymowski

  • 0 Posts
  • 0 Likes
Funny thing. I deleted all registry entries in HKCU/Keyboard layout/Preload and Subtitles. Entered only polish keyboard but it appeared that I cannot choose now any keyboard. I then tried to restore my windows 7 to the previous point but it hanged in initialize point. I had to switch computer off. When I switched it on I see only black screen now with information : BOOTMGR is missing. HAHAHA!!! I destroyed windows 7 when tried to fix alt+s now I regret I started to try. So many hours lost :(
I wanted to have windows XP but unfortunately new HP Pavilon is not supporting win XP. Only OS that worked for me. Everything else is rubbish. Painful rubbish...|!!!!!!!!!

Giacomo 'Peldi' Guilizzoni, Official Rep

  • 2122 Posts
  • 153 Likes
Hi there, I think I got it. Can you please try http://balsamiq.com/products/mockups/... ?

Let me know how it goes!

jan.mysior

  • 2 Posts
  • 3 Likes
Hi Giacomo,
this next release does help in a way that it prevents alt+z to behave as ctrl+z (which is a big step ahead). However I still cannot input the "ż" sign. Inside the text input alt+z combination does nothing, while it should input the "ż" letter.

Giacomo 'Peldi' Guilizzoni, Official Rep

  • 2122 Posts
  • 153 Likes
Thanks Jan, little by little we'll get it! :)

Giacomo 'Peldi' Guilizzoni, Official Rep

  • 2122 Posts
  • 153 Likes

jan.mysior

  • 2 Posts
  • 3 Likes
Hi!
It works! That is just great - good job.
Thank you very much and thanks for creating and maintaining my favourite tool :-)
Best regards

Dawid Ciecierski

  • 0 Posts
  • 0 Likes
Giacomo, I'm a Polish desktop user and have been having issues with AltGr+s (right alt) all along. Googled it just now because having to go into notepad, type AltGr+s, select, copy, come back to Balsamiq, edit label or paragraph, and paste the letter "ś," has grown a little tiring to say the least.

I came across this thread and was happy to read this was fixed in v2... But then discovered we're using the latest v2.1.19 and still having the same problem! How is that possible? Do I need to reset Balsamiq's keyboard shortcuts somehow?

BM M

  • 2 Posts
  • 0 Likes
How come this problem is marked as solved? I just downloaded Balsamiq and have the issue with RightAlt + s, instead of typing ś it just closes the edited text.

Has anybody came up with a working solution? (other than copy paste from notepad)

Karolina Kuczko

  • 0 Posts
  • 0 Likes
Yes, switching from Balsamique to Serena ;-)

Florian Brauer, EMPLOYEE

  • 354 Posts
  • 22 Likes
Sorry... I do not know either why this was marked as solved. Because you are right it is not fixed. For windows and possibly for Linux

We do not have any shortcut on "alt + s" or "right alt + s".

So I did some digging.

I had the keyboard testprogramm still around which I used for the caps lock issue that certain events did not get treated correctly when caps lock was pressed. I am absolutely dumbstruck about the result.

Adobe translates the right alt to two keys: ctrl and left alt.

Now what happens?

On "ctrl + alt + s" we have a shortcut - save all. This is handled by the NativeMenu about which I already wrote a blog post. (might have to update it at some point ... about language support)

I continue digging how we can solve this ...

BM M

  • 2 Posts
  • 0 Likes
The workaround (not solution!) for someone who knows Autohotkey is to use a special mapping script, like described here: http://www.autohotkey.com/community/v...

Dawid Ciecierski

  • 0 Posts
  • 0 Likes
Florian, Giacomo, can you update us on when this is going to be resolved?

Cannot help but feel rather ignored and neglected. Except for promises that someone is working on a solution this has not been acted upon for three years while we are annoyed by this oversight on a daily basis.

This is not how I'd like to be treated as a paying customer.

Florian Brauer, EMPLOYEE

  • 354 Posts
  • 22 Likes
And I heared you. You can test the prerelease and ś should work in it.
http://www.balsamiq.com/products/mock...

But enabling the letter meant to disable the keyboard shortcut "Save All" during editing text. Save All is still availible via the menu during text edit. The shortcut gets enabled as soon as you leave the text edit mode.

Can one of you please give us a list of other key combinations that conflict or are not working with "letter on the keyboard + modification key".

Dawid Ciecierski

  • 0 Posts
  • 0 Likes
Florian, I can confirm that it does work indeed! Thank you for solving this at long last, and fingers crossed this "bugfix" makes it into a production release soon.

Florian Brauer, EMPLOYEE

  • 354 Posts
  • 22 Likes
Hello everybody,

This is finally fixed in the new version we shipped today.
Check out the release notes here:
http://blogs.balsamiq.com/product/201...

For downloading the new Desktop version please click here:
http://www.balsamiq.com/download

Enjoy!