Lost work even though I didnt actually close balsamiq

  • Problem
  • Updated 3 years ago
  • Solved
Archived

This conversation was archived and is no longer visible to community members.

I wanted to close a session without realizing i had some unsaved work. On clicking the close button I was prompted to save. I clicked the OK button on the dialog and then pressed ctrl S but it closed my New Mockup page which had the unsaved work and I haven't been able to recover it. I am quite puzzled. Why didn't it save the file?

I tried to look for some information on your help pages and saw some information about recovering a file from the local cache. I didn't find anything that would look like a bmml file and also didnt see any information about how to recover the file.
Photo of Revathi NathanielRN

Revathi Nathaniel

  • 3 Posts
  • 0 Likes
  • confused and sad I have to redo my work.

Posted 3 years ago

  • 1
Photo of Michael Angeles

Michael Angeles, Employee

  • 3760 Posts
  • 186 Likes
Hi, Revathi. Ugh, I'm sorry to hear this happened. The auto-recover works primarily for applications crashes, but it sounds like the App may have saved the file in focus (the currently visible Mockup tab) and closed without saving others. Is this what you're seeing?

I think I may have been able to reproduce the bug doing this:

1) Open 2 files and make them dirty
2) Select Balsamiq Mockups > Quit
3) Press Ctrl+S when save dialog appears

In this case, it looks like file 1 (the one in focus) saves, but file 2 does not. This is because CTRL+S is mapped to save a single file, but it shouldn't be enabled when that dialog appears.

I'm really sorry this happened, and am filing the bug report for the dev team to look at this.
Photo of Revathi NathanielRN

Revathi Nathaniel

  • 3 Posts
  • 0 Likes
Great. Thanks for your reply.
Photo of Giacomo 'Peldi' Guilizzoni

Giacomo 'Peldi' Guilizzoni, Official Rep

  • 5887 Posts
  • 457 Likes
Photo of Revathi NathanielRN

Revathi Nathaniel

  • 3 Posts
  • 0 Likes
Thank you Balsamiq! :)