right ALT + s does save instead of puting glyph ś - polish diacritic mark.

  • Problem
  • Updated 1 year ago
  • Solved
Archived

This conversation was archived and is no longer visible to community members.

It appears that problem mentioned and resolved here (http://gsfn.us/t/o1un) reappeared from version 2.1.15 and higher (including pre-release). In version 2.1.14 right alt+s worked just fine - printing "ś".

As it was mentioned before, it is quiet common letter in polish language so it would be nice to be able to write it straight from the keyboard :).

Problem does not concern upper-case Ś (shift+right alt+s).

I've confirmed this on Win 7 32 bit. Air version 11.2.202.223 Balsamiq (mockups for desktop) versions 2.1.15/ 2.1.16/ 2.1.17/ 999.234.

gk.klimek

  • 0 Posts
  • 0 Likes
  • irritated

Posted 2 years ago

  • 2

Giacomo 'Peldi' Guilizzoni, Official Rep

  • 2122 Posts
  • 153 Likes
So sorry about that gk, I can't believe we broke this again. We'll fix it soon, and write a test so that it doesn't break any more.

Wojciech Pająk

  • 0 Posts
  • 0 Likes
Is this bug still "under construction"?

Florian Brauer, EMPLOYEE

  • 356 Posts
  • 22 Likes
I can tell you the cause for the error.

"right alt" gets mapped as TWO keys on a windows computer. Every other key is mapped as individual key that emits only one event. The trouble with "right alt" is that it emits two and the these are CTRL and ALT.

On CTRL + ALT + S we have the shortcut Save All which triggers. Even though you did not press CTRL.

Now you know why your keyboard shortcut does not have the desired effect.

Wojciech Pająk

  • 0 Posts
  • 0 Likes
Thank you for the explanation :)
Now I need to know when the problem will be solved (keeping in mind your Polish customers).
Probably you could change this shortcut for us?
It is the only one that cases conflict, the others: żźęółąćń and even big ś (Ś) don't mess so much.

Florian Brauer, EMPLOYEE

  • 356 Posts
  • 22 Likes
And I heared you. You can test the prerelease and ś should work in it.
http://www.balsamiq.com/products/mock...

But enabling the letter meant to disable the keyboard shortcut "Save All" during editing text. Save All is still availible via the menu during text edit. The shortcut gets enabled as soon as you leave the text edit mode.

Wojciech Pająk

  • 0 Posts
  • 0 Likes
It works! Thanks A LOTŚŚŚŚ!

Florian Brauer, EMPLOYEE

  • 356 Posts
  • 22 Likes
Hello everybody,

This is finally fixed in the new version we shipped today.
Check out the release notes here:
http://blogs.balsamiq.com/product/201...

For downloading the new Desktop version please click here:
http://www.balsamiq.com/download

Enjoy!