Changing/resetting a users password

  • Question
  • Updated 1 year ago
  • Answered
Archived

This conversation was archived and is no longer visible to community members.

When I change a users password, the page says "Change your password" and asks for current password. Is this right?

Mike Green

  • 10 Posts
  • 0 Likes

Posted 3 years ago

  • 1

Louanne Poisson

  • 791 Posts
  • 20 Likes
Hey Mike,

Yes. That is correct.

Dr Cris Bloomfield

  • 1 Post
  • 0 Likes
That's daft. In My Balsamiq users set their own passwords in response to an email invitation - they're not set by the admin. If they have forgotten it, the wording on the password reset page tells them to contact the admin to reset it.

The admin can't reset it for the user because any user with a grain of intelligence won't have told anyone else their password. As a result this function to reset a user password as an admin is utterly pointless in the real world. Neither the user or admin knows the password and can't reset it via this route.

Please fix this.

Florian Brauer, EMPLOYEE

  • 356 Posts
  • 22 Likes
Changing password scenarios:
- You know your password and can login and want to change it. -> You enter the in the change password site the new password twice. The change password site is availible via user informations when you are loged in.

- You do not know your password but you still have access to your email that you used for registration. -> Reset the password via "I forgot my password link" that is on each login screen and follow the instructions you get by mail.

- Third option contact your site admin and he changes your password in myBalsamiq. He does not need your current password. He should also tell you the new password.
For changing the password he has to go to the staff members or non staff members depending on the group you are in. Below the avatar he can open a menu in which he can select to change your password.

Dr Cris Bloomfield

  • 1 Post
  • 0 Likes
Florian,

Under option 3 that you outline you still need to know the user password. You cannot reset the password without it. Tried and tested earlier today as the MyBalsamiq admin.

Regards

Cris

Florian Brauer, EMPLOYEE

  • 356 Posts
  • 22 Likes
Okay here are the steps for it with screenshots.

1. Going to the staff menu with the user either Staff Member or Non-Staff Member.
2. Select the user you want to change the password for.


3. Select change password. You only see this option if you selected yourself or you are the site owner.



4. Enter new password for the user in the two fields. You do not need the original password.
5. Save the changes.

Dr Cris Bloomfield

  • 1 Post
  • 0 Likes
I appreciate that is what is supposed to happen, but it is not happening ;)

I am the site owner for our MyBalsamiq instance:



As stated earlier in this thread, when I try and change the password for a user I have to enter their current password. It is a required field and I cannot progress with out it:



Hence posting for some support!

Dr Cris Bloomfield

  • 1 Post
  • 0 Likes
Please can you advise if it has been possible to address this issue?

Florian Brauer, EMPLOYEE

  • 356 Posts
  • 22 Likes
Hello Cris,

I am sorry for all this trouble. I talked with our developer and the view for site owner and admin should be identical which it is not the case. The site owner should not get asked for the current password.

This will be fixed with the next release.

To solve the current issue you have I can only offer you that we reset the password for you. So please sent us per email (support@balsamiq.com) for whom you want to change the password.

Dr Cris Bloomfield

  • 1 Post
  • 0 Likes
Thanks for the clarification. The user in question has reset via the email route in this case which should solve almost all of our immediate concerns.

Florian Brauer, EMPLOYEE

  • 356 Posts
  • 22 Likes
Hello Cris,

This is finally fixed in the new version we shipped today.
Check out the release notes here:
http://blogs.balsamiq.com/product/201...

Enjoy!

Dr Cris Bloomfield

  • 1 Post
  • 0 Likes
Great thanks for this, just tested it and it's working fine.