"Image not found" for Confluence mockups

  • Problem
  • Updated 2 months ago
  • In Progress
After upgrading to Confluence 4.3 and Balsamiq 2.2.2 image attachments cannot be added to mockups anymore. Balsamiq just displays the regular image placeholder with "Image not found" added.

The attachment preview however works as intended. It looks like the cause is an incorrect mine-type for the images (text/html instead of image/png).
Photo of AndreasA

Andreas

  • 2 Posts
  • 0 Likes

Posted 2 years ago

  • 5
Photo of KyleK

Kyle

  • 108 Posts
  • 6 Likes
Hello Andreas,

I just responded to your support ticket.
Photo of WilmW

Wilm

  • 2 Posts
  • 0 Likes
Dear Kyle,

we have the same problem, is there a solution for it?

Regards,
Wilm
Photo of Marco

Marco

  • 3 Posts
  • 0 Likes
Hi Kyle

Same problem on our side too. Confluence 4.3.2 and Balsamiq 2.2.2. Is there a bug fix or workaround available?

Regards,

Marco
Photo of AndreasA

Andreas

  • 2 Posts
  • 0 Likes
Just to let you know: Balsamiq tech support is still investigation the issue. There is no solution for this right now.

Regards,
Andreas
Photo of Jack Lindsay

Jack Lindsay

  • 1 Post
  • 0 Likes
I would like to add my voice to this. Balsamiq won't show any attachments in Confluence 4.3.2 and Balsamiq 2.2.2 for us either.
Photo of KyleK

Kyle

  • 108 Posts
  • 6 Likes
Hello folks,

Andreas correctly diagnosed the issue and it was introduced with the new Confluence 4.3.2. We have a fix for it with this pre-release version: http://builds.balsamiq.com/b/Next/moc...

The fix will be in the official release: mockupsConfluence-2.2.3.obr. We should have that version out by the end of Nov/beginning of Dec.

Thanks Andreas!
Photo of Marco

Marco

  • 3 Posts
  • 0 Likes
Hi Kyle

Is there a new download link available because the given one does not seem to work?

Thanks.
Photo of Marco

Marco

  • 3 Posts
  • 0 Likes
Sorry I didn't see that the build nr increases daily. Found it now: http://builds.balsamiq.com/b/Next/moc...
Photo of OliverO

Oliver

  • 4 Posts
  • 0 Likes
Marco: Link doesn't work
Photo of OliverO

Oliver

  • 4 Posts
  • 0 Likes
Thanks. Urgently needed!
Photo of OliverO

Oliver

  • 4 Posts
  • 0 Likes
Any news about the announced fix? We need this very urgently. Thanks.
Photo of Paul BPB

Paul B

  • 6 Posts
  • 0 Likes
We are also looking for an update on when this will be available.

The latest pre-release (http://www.balsamiq.com/products/mock...) does fix this specific issue, but appears to introduce another bug when saving where the cursor icon stays as a clock, even after the save has completed.

This creates additional confusion and as a result, we aren't able to deploy it in our environment.
Photo of davetD

davet

  • 7 Posts
  • 0 Likes
It would seem that Version: 999.1407 is worse than 999.1384
i.e. "image not found" AND clock cursor :(

I know that it is early in the year but this has been dragging on for a couple of months!
Photo of behrangsaB

behrangsa

  • 2 Posts
  • 0 Likes
Just purchased Balsamiq Desktop a few days ago and all my images are lost after I reopen my documents.

This is not any good guys!
Photo of Ben Norris

Ben Norris, Official Rep

  • 3636 Posts
  • 179 Likes
I replied in your other thread (http://community.balsamiq.com/balsami...).
Photo of OliverO

Oliver

  • 4 Posts
  • 0 Likes
Are there any (good) news about this subject?
Highly appreciated ;-)
Photo of Ben Norris

Ben Norris, Official Rep

  • 3636 Posts
  • 179 Likes
We are so sorry that this has taken longer than we have been hoping. We are really close to getting this out now, and hope that it will be available in the next couple weeks. We will definitely keep you updated!
Photo of Eriks Nukis

Eriks Nukis

  • 1 Post
  • 0 Likes
Fix for this would be highly appreciated! Thanks!
Photo of Florian Brauer

Florian Brauer, EMPLOYEE

  • 680 Posts
  • 51 Likes
Hello everybody,

This is finally fixed in the new version we shipped today.
Check out the release notes here:
http://blogs.balsamiq.com/product/201...

Enjoy!
Photo of Felix NiedererFN

Felix Niederer

  • 2 Posts
  • 0 Likes
Hi, I am using Balsamiq Mockups for Confluence (OnDemand), but I don't see the images.

My Version:
Balsamiq Mockups for Confluence
Version: 999.1502 - 02/16/2013
Editor Version: 999.875 - 02/16/2013 07:19
Flash Player Version: WIN 11,6,602,180

Felix.
Photo of Ben Norris

Ben Norris, Official Rep

  • 3636 Posts
  • 179 Likes
Felix, can you try updating to the latest version? It looks like you are on an older pre-release version. You can get it here: https://marketplace.atlassian.com/plu.... Let me know if you still have problems! Thanks.
Photo of Felix NiedererFN

Felix Niederer

  • 2 Posts
  • 0 Likes
Ben, how do I update Balsamiq on Confluence OnDemand? I thought everyone uses the same version.
Photo of Giacomo 'Peldi' Guilizzoni

Giacomo 'Peldi' Guilizzoni, Official Rep

  • 5887 Posts
  • 457 Likes
Hi Felix, you are correct, everyone on Atlassian OnDemand uses the same version which Atlassian updates periodically. I just replied to you via email to try and debug your image not found issue.
Photo of vbelangerV

vbelanger

  • 2 Posts
  • 0 Likes
I am having this problem today in Confluence Could with Balsamiq 2.2.25.  Any help would be appreciated.  Thanks!
Photo of vbelangerV

vbelanger

  • 2 Posts
  • 0 Likes
I was able to resolve this when I save the mockup, and then save the confluence page.  It feels like a tough workaround though...any progress on being able to upload images on a Confluence page that hasn't been saved?
Photo of Sax Cammarata

Sax Cammarata, Employee

  • 41 Posts
  • 1 Like
Hi Vbelanger,
Sorry for the hassle and you are right, the workaround of saving the page before being able to upload an image is quite annoying.

Actually we are planning a major revamp of the Confluence plugin that will solve this and many other issue.

Sorry again for the snag, we are working hard in order to improve our product.